博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
hdu 1069 Monkey and Banana
阅读量:5323 次
发布时间:2019-06-14

本文共 3250 字,大约阅读时间需要 10 分钟。

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3987    Accepted Submission(s): 2053

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

 

Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
 

 

Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
 

 

Source
 

 

Recommend
JGShining

//本题关键的对长宽的表示和排序

//之后就是简单的动规了

#include <iostream>

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#define N 200
using namespace std;
struct node
{
    int x,y,h;
    bool operator <(const node&a)const
    {
        if(x==a.x)
          return y>a.y;
        return x>a.x;
    }
    void get(int &a,int &b,int &c)
    {
        x=a;y=b;h=c;
    }
}a[N];
int h[N];
bool is(node &a,node&b)
{
    if(a.x<b.x&&a.y<b.y)
     return true;
    return false;
}
int main()
{
    int x,y,z;
    int n,k,i,t=1;
    a[0].x=a[0].y=1000000000;
    while(scanf("%d",&n),n)
    {
        for(i=k=1;i<=n;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            a[k++].get(x,y,z);
            a[k++].get(y,x,z);
            a[k++].get(x,z,y);
            a[k++].get(z,x,y);
            a[k++].get(y,z,x);
            a[k++].get(z,y,x);
        }
        n=k-1;int Max=0;
        sort(a+1,a+n+1);
        for(i=1;i<=n;Max=max(Max,h[i]),i++)
         for(h[i]=k=0;k<i;k++)
          if(is(a[i],a[k])&&h[k]+a[i].h>h[i])
             h[i]=h[k]+a[i].h;
        printf("Case %d: maximum height = %d\n",t++,Max);
    }
    return 0;
}

转载于:https://www.cnblogs.com/372465774y/archive/2012/08/01/2618174.html

你可能感兴趣的文章
iphone常见机型微信网页可视高度
查看>>
移动混合开发之HTML5在移动开发中的准则
查看>>
以Qemu模拟Linux,学习Linux内核
查看>>
Hadoop 综合大作业
查看>>
hexo安装
查看>>
python日期及时间格式转换
查看>>
MSP与PSP
查看>>
Android 使用RecyclerView SnapHelper详解
查看>>
Android开发学习:[15]自动导入包
查看>>
Struts2+JFreeChart
查看>>
touch事件记录
查看>>
[C语言 - 9] typedef
查看>>
在100万个数中找到最大的十个数
查看>>
java.io.File中的绝对路径和相对路径
查看>>
spring boot项目升级到2.0.1,提示java.lang.ClassNotFoundException: org.apache.log4j.Logger错误...
查看>>
二、Spring容器使用
查看>>
字符串:格式化 - 零基础入门学习Python015
查看>>
第一个程序 - Windows程序设计(SDK)001
查看>>
二分法原理
查看>>
容器和算法2 - C++快速入门48(完)
查看>>